Home » Server Options » RAC & Failsafe » setting Firewire 800 for RAC (Firewire Modules not loading or not compatible with the kernel version (OS: Oracle Linux Enterprise Edition 5.1)
setting Firewire 800 for RAC (Firewire Modules not loading or not compatible with the kernel version [message #359003] Thu, 13 November 2008 04:57
Messages: 1
Registered: April 2008
Junior Member
I trying build a RAC setup. How can I configure the firewire port?

Getting error FATAL ieee1394 module not found

Hardware Details
OS: Oracle Linux Enterprise Edition 5.1
uname -a
Linux kernel-2.6.18-53.el5.x86_64

Hardware Details
CPU AMD64 Anthlon 5000+ Dual Core
3 port firewire 800 9 pin PCI card

Shared Storage
LaCie d2 Quadra Hard Drive
eSATA 1.5Gbits, FireWire 800 (2 ports), FireWire 400, Hi-Speed USB 2.0

I tried this work around but still getting same error

Option 1: The first one is to load the kernel installed by the firewire module, if you are not very particular about the kernel version. Once the firewire modules are installed, the /etc/grub.conf is populated with the Firewire kernel and which looks some thing like this:

#cat /etc/grub.conf
# grub.conf generated by anaconda
# # Note that you do not have to rerun grub after making changes to this file
# NOTICE: You do not have a /boot partition. This means that
# all kernel and initrd paths are relative to /, eg.
# root (hd0,1)
# kernel /boot/vmlinuz-version ro root=/dev/sda2
# initrd /boot/initrd-version.img
title Enterprise (2.6.9-
root (hd0,1)
kernel /boot/vmlinuz-2.6.9- ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.9-
title Enterprise-smp (2.6.9-
root (hd0,1)
kernel /boot/vmlinuz-2.6.9- ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.9-
title Enterprise-up (2.6.9- root (hd0,1) kernel /boot/vmlinuz-2.6.9- ro root=LABEL=/ rhgb quiet initrd /boot/initrd- 2.6.9-
title Other
rootnoverify (hd0,0)
chainloader +1

The entries in orange color are the ones which have been populated by the Firewire modules/kernel. To load your OS using this kernel, you simply have to update the grub.conf to use that kernel to load by modifying the default=0 to default=2. That should all, when you boot next time using the Firewire modules/kernel, you should be able to load the sbp2, ohci1394 and ieee1394 modules without any problems.

Option 2:
1. When you install oracle-firewire-modules-2.6.9-42.0.3.EL-1286-1.i686.rpm rpm it will install the modules under /lib/modules/2.6.9-42.0.3.EL/kernel/drivers/ieee1394, but your existing kernel would be as indicated by `uname -r`. In my case it was 2.6.9-
2. Make a directory ieee1394 under /lib/modules/2.6.9-
3. copy the modules which have been installed under /lib/modules/2.6.9-42.0.3.EL/kernel/drivers/ieee1394 to /lib/modules/2.6.9-
4. Then run the following commands:
#depmod -a ieee1394.ko;modprobe ieee1394
#depmod -a ohci1394.ko;modprobe ohci1394
#depmod -a pcilynx.ko;modprobe pcilynx
#depmod -a raw1394.ko;modprobe raw1394

Update the etc/modprobe.conf. For example, the entry in the /etc/modprobe.conf file would be: options sbp2 exclusive_login=0

Now you should be able to load the Firewire modules without changing your kernel.

Checking the integrity of the downloaded firewire module:

$md5sum oracle-firewire-modules-2.6.9-42.0.3.EL-1286-1.i686.rpm
7fe3c83291ffab284f6f941b717dacb1 oracle-firewire-modules-2.6.9-42.0.3.EL-1286-1.i686.rpm

Verify the above code (7fe3c83291ffab284f6f941b717dacb1) with that
indicated in the source website.

Previous Topic: configuration scripts
Next Topic: Problem configuring Fail Safe
Goto Forum:

Current Time: Thu Jun 01 20:18:04 CDT 2023